Netbeans under OS X

Jag har som många andra haft problem att köra Netbeans med min default-användare i OS X. Det enda som hänt är att applikationen visat sig i dockan och har sedan efter någon sekund avbrutits och därmed försvunnit från dockan. Problemet verkar ha att göra med en inställning som berör 64/32 bitar under OS X. Det fungerade dock alltid bra när jag körde Netbeans som root (sudo)…

Jag körde iaf. följande kommandon för att råda bot på problemen:

  1. sudo -s
  2. cp -p /System/Library/Frameworks/JavaVM.framework/Versions/1.5/Home/bin/java /tmp/java_original_binary
  3. lipo /System/Library/Frameworks/JavaVM.framework/Versions/1.5/Home/bin/java -remove x86_64 -output /tmp/java
  4. cat /tmp/java > /System/Library/Frameworks/JavaVM.framework/Versions/1.5/Home/bin/java

Nu fungerar det även bra att köra Netbeans under mitt vanliga användarkonto!

Annonser

Publicerad av Erik Ellingsson

Amateur actor, Sceptic and IT consultant with interest for Hockey (of course for my local team - Luleå Hockey), Environmental issues, Photography and Golf.

Lämna en kommentar

Fyll i dina uppgifter nedan eller klicka på en ikon för att logga in:

WordPress.com Logo

Du kommenterar med ditt WordPress.com-konto. Logga ut /  Ändra )

Google-foto

Du kommenterar med ditt Google-konto. Logga ut /  Ändra )

Twitter-bild

Du kommenterar med ditt Twitter-konto. Logga ut /  Ändra )

Facebook-foto

Du kommenterar med ditt Facebook-konto. Logga ut /  Ändra )

Ansluter till %s

%d bloggare gillar detta: